<!DOCTYPE html>
<html lang="en-us" dir="ltr">
<head>
    <base href="https://www.primenewsghana.com/politics/adu-boahen-cited-for-conflict-of-interest-ahead-of-vetting-tomorrow.html" />    <link href="https://www.primenewsghana.com/templates/pknews/images/designer/77ad1d8e7dfa21895565467f12935c15_favicon.ico" rel="icon" type="image/x-icon" />
    <script>
    var themeHasJQuery = !!window.jQuery;
</script>
<script src="/templates/pknews/jquery.js?version=1.0.2838"></script>
<script>
    window._$ = jQuery.noConflict(themeHasJQuery);
</script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
<script src="/templates/pknews/bootstrap.min.js?version=1.0.2838"></script>
<!--[if lte IE 9]>
<script src="/templates/pknews/layout.ie.js?version=1.0.2838"></script>
<link rel="stylesheet" href="/templates/pknews/layout.ie.css?version=1.0.2838" media="screen"/>
<![endif]-->
<link class="" href='//fonts.googleapis.com/css?family=Roboto:100,100italic,300,300italic,regular,italic,500,500italic,700,700italic,900,900italic|Roboto+Condensed:300,300italic,regular,italic,700,700italic|Amaranth:regular,italic,700,700italic|Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic|Ubuntu:300,300italic,regular,italic,500,500italic,700,700italic|Francois+One:regular|Actor:regular&subset=latin' rel='stylesheet' type='text/css'>
<script src="/templates/pknews/layout.core.js?version=1.0.2838"></script>
    
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
	<meta name="keywords" content="Ghana Political News, NDC News, NPP News, Election 2016 Campaign News, Primenewsghana.com." />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:site" content="@primenewsghana" />
	<meta name="twitter:creator" content="@primenewsghana" />
	<meta name="twitter:title" content="Adu-Boahen cited for conflict of interest ahead of vetting tomorrow" />
	<meta name="twitter:description" content="Deputy Ranking Member on Parliament’s Finance Committee, Isaac Adongo, has cited Minister of State-designate at the Finance Ministry, Dr Charles Adu Boahen, for being in a conflict-of-interest situation that makes him unfit for the job." />
	<meta name="twitter:image" content="https://www.primenewsghana.com/images/2021/may/01/Charles-Adu-Boahen.jpg" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta property="og:site_name" content="Prime News Ghana" />
	<meta property="og:title" content="Adu-Boahen cited for conflict of interest ahead of vetting tomorrow" />
	<meta property="og:type" content="article" />
	<meta property="article:published_time" content="2021-06-01T16:20:29+00:00" />
	<meta property="article:modified_time" content="2021-06-01T16:20:29+00:00" />
	<meta property="article:author" content="https://www.facebook.com/primenewsghana" />
	<meta property="article:section" content="Politics" />
	<meta property="og:url" content="https://www.primenewsghana.com/politics/adu-boahen-cited-for-conflict-of-interest-ahead-of-vetting-tomorrow.html" />
	<meta property="og:description" content="Deputy Ranking Member on Parliament’s Finance Committee, Isaac Adongo, has cited Minister of State-designate at the Finance Ministry, Dr Charles Adu Boahen, for being in a conflict-of-interest situation that makes him unfit for the job." />
	<meta property="og:image" content="https://www.primenewsghana.com/images/2021/may/01/Charles-Adu-Boahen.jpg" />
	<meta name="description" content="Ghana politics and current affairs news headlines and stories. " />
	<meta name="generator" content="Joomla! - Open Source Content Management" />
	<title>Adu-Boahen cited for conflict of interest ahead of vetting tomorrow - Prime News Ghana</title>
	<link href="https://www.primenewsghana.com/politics/adu-boahen-cited-for-conflict-of-interest-ahead-of-vetting-tomorrow.amp.html" rel="amphtml" />
	<link href="https://www.primenewsghana.com/politics/adu-boahen-cited-for-conflict-of-interest-ahead-of-vetting-tomorrow.html" rel="canonical" />
	<link href="/media/plg_content_osembed/css/osembed.css?51a3950c50505d7f5d8217ed8913f870" rel="stylesheet" type="text/css" />
	<link href="/modules/mod_raxo_allmode/tmpl/allmode-default/allmode-default1.css" rel="stylesheet" type="text/css" />
	<script src="/templates/pknews/js/jui/jquery.min.js?e6266c3fd9f4515b78d78e56142ce220" type="text/javascript"></script>
	<script src="/templates/pknews/js/jui/jquery-noconflict.js?e6266c3fd9f4515b78d78e56142ce220" type="text/javascript"></script>
	<script src="/media/jui/js/jquery-migrate.min.js?e6266c3fd9f4515b78d78e56142ce220" type="text/javascript"></script>
	<script src="/media/plg_content_osembed/js/osembed.min.js?51a3950c50505d7f5d8217ed8913f870" type="text/javascript"></script>
	<meta property="og:title" content="Adu-Boahen cited for conflict of interest ahead of vetting tomorrow" />
	<meta property="og:type" content="article" />
	<meta property="og:image" content="https://www.primenewsghana.com/images/2021/may/01/Charles-Adu-Boahen.jpg" />
	<meta property="og:url" content="https://www.primenewsghana.com/politics/adu-boahen-cited-for-conflict-of-interest-ahead-of-vetting-tomorrow.html" />
	<meta property="og:site_name" content="Prime News Ghana" />
	<meta property="og:description" content="Deputy Ranking Member on Parliament’s Finance Committee, Isaac Adongo, has cited Minister of State-designate at the Finance Ministry, Dr Charles Adu Boahen, for being in a conflict-of-interest situation that makes him unfit for the job. " />
	<meta property="fb:app_id" content="1396450703736402" />
	<!-- Start: Google Structured Data -->
             <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "BreadcrumbList", "itemListElement": [ { "@type": "ListItem", "position": 1, "name": "Home", "item": "https://www.primenewsghana.com/" }, { "@type": "ListItem", "position": 2, "name": "Politics", "item": "https://www.primenewsghana.com/politics.html" }, { "@type": "ListItem", "position": 3, "name": "Adu-Boahen cited for conflict of interest ahead of vetting tomorrow", "item": "https://www.primenewsghana.com/politics/adu-boahen-cited-for-conflict-of-interest-ahead-of-vetting-tomorrow.html" } ] } </script> <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "Article", "mainEntityOfPage": { "@type": "WebPage", "@id": "https://www.primenewsghana.com/politics/adu-boahen-cited-for-conflict-of-interest-ahead-of-vetting-tomorrow.html" }, "headline": "Adu-Boahen cited for conflict of interest ahead of vetting tomorrow", "description": "Deputy Ranking Member on Parliament’s Finance Committee, Isaac Adongo, has cited Minister of State-designate at the Finance Ministry, Dr Charles Adu Boahen, for being in a conflict-of-interest situation that makes him unfit for the job.", "image": { "@type": "ImageObject", "url": "https://www.primenewsghana.com/images/2021/may/01/Charles-Adu-Boahen.jpg" }, "author": { "@type": "Person", "name": "George Nyavor" }, "publisher": { "@type": "Organization", "name": "Primenewsghana.com", "logo": { "@type": "ImageObject", "url": "https://www.primenewsghana.com/images/2018/dec/1NEW-PRIME-LOGO.png" } }, "datePublished": "2021-06-01T16:20:29+00:00", "dateCreated": "2021-06-01T16:20:29+00:00", "dateModified": "2021-06-01T16:20:29+00:00" } </script> <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "Article", "mainEntityOfPage": { "@type": "WebPage", "@id": "https://www.primenewsghana.com/politics/adu-boahen-cited-for-conflict-of-interest-ahead-of-vetting-tomorrow.html" }, "headline": "Adu-Boahen cited for conflict of interest ahead of vetting tomorrow", "description": "Deputy Ranking Member on Parliament’s Finance Committee, Isaac Adongo, has cited Minister of State-designate at the Finance Ministry, Dr Charles Adu Boahen, for being in a conflict-of-interest situation that makes him unfit for the job.", "image": { "@type": "ImageObject", "url": "https://www.primenewsghana.com/images/2021/may/01/Charles-Adu-Boahen.jpg" }, "author": { "@type": "Person", "name": "George Nyavor" }, "publisher": { "@type": "Organization", "name": "Primenewsghana.com", "logo": { "@type": "ImageObject", "url": "https://www.primenewsghana.com/images/2018/dec/1NEW-PRIME-LOGO.png" } }, "datePublished": "2021-06-01T16:20:29+00:00", "dateCreated": "2021-06-01T16:20:29+00:00", "dateModified": "2021-06-01T16:20:29+00:00" } </script>
            <!-- End: Google Structured Data -->
	<meta property="article:publisher" content="https://www.facebook.com/primenewsghana" />
<meta name="google-site-verification=FMW1kPMU-CG1F001ybGt-9qN7yGsGNAWpf2wNjOtHEs"/>
<meta property="article:tag" content="Ghana News" />
<meta property="twitter:site" content="@primenewsghana">
<meta name="theme-color" content="#f92306">
<meta property="fb:pages" content="1715906461955288" />
<meta property="fb:app_id" content="1396450703736402" />
<meta property="fb:app_id" content="1966226610280053" />
<meta property="og:image:width" content="600"/>
<meta property="og:image:height" content="400"/>
<script type="text/javascript" defer>
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/primenewsghana/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
<!-- Start Alexa Certify Javascript -->
<script type="text/javascript" defer>
_atrk_opts = { atrk_acct:"q5Nao1IW1810vg", domain:"primenewsghana.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=q5Nao1IW1810vg" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->  
<script type='text/javascript' async src='https://platform-api.sharethis.com/js/sharethis.js#property=5ed7ae6432086700128ada45&product=inline-share-buttons' async='async'></script>
        <link rel="stylesheet" href="/templates/pknews/css/bootstrap.min.css?version=1.0.2838" media="screen" />
            <link rel="stylesheet" href="/templates/pknews/css/template.min.css?version=1.0.2838" media="screen" />
            <script async src="/templates/pknews/script.js?version=1.0.2838"></script>
    


<script src="/plugins/system/GoogleAnalytics/vendor/directmonster2.0.2.js" type="text/javascript"></script> 
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-78977309-1', 'auto');
  ga('require', 'linkid', 'linkid.js');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');
</script>
<!-- Universal Google Analytics PRO 4.6.3 Plugin by PB Web Development -->


</head>
<body class=" bootstrap bd-body-6  bd-pagebackground-33 bd-margins">
    <header class=" bd-headerarea-1 bd-margins">
        <div class=" bd-layoutbox-1 bd-no-margins clearfix">
    <div class="bd-container-inner">
        <form id="search-8" role="form" class=" bd-search-8 hidden-sm hidden-xs form-inline" name="search" action="/index.php" method="post">
    <div class="bd-container-inner">
        <input type="hidden" name="task" value="search">
        <input type="hidden" name="option" value="com_search">
        <div class="bd-search-wrapper">
            
                
                <div class="bd-input-wrapper">
                    <input type="text" name="searchword" class=" bd-bootstrapinput-11 form-control input-sm" placeholder="Search Prime news ghana">
                </div>
                
                <div class="bd-button-wrapper">
                    <input type="submit" class=" bd-button-18 bd-no-margins" value="Search" link-disable="true">
                </div>
        </div>
        <script>
            (function (jQuery, $) {
                jQuery('.bd-search-8 .bd-icon-58').on('click', function (e) {
                    e.preventDefault();
                    jQuery('#search-8').submit();
                });
            })(window._$, window._$);
        </script>
    </div>
</form>
	
		        	
		<a class=" bd-logo-3" href="https://www.primenewsghana.com"
 title="ghana news on prime news ghana">
<img class=" bd-imagestyles-11" src="https://www.primenewsghana.com/images/2018/dec/1NEW-PRIME-LOGO.png" alt="Prime News Ghana">
</a>
	
		<h3 class=" bd-textblock-2 hidden-sm hidden-xs bd-content-element">
    Prime News Ghana</h3>
	
		<form id="search-6" role="form" class=" bd-search-6 hidden-md hidden-lg form-inline" name="search" action="/index.php" method="post">
    <div class="bd-container-inner">
        <input type="hidden" name="task" value="search">
        <input type="hidden" name="option" value="com_search">
        <div class="bd-search-wrapper">
            
                <input type="text" name="searchword" class=" bd-bootstrapinput-22 form-control input-sm" placeholder="Search Prime News">
                <a href="#" class="bd-icon-132 bd-icon " link-disable="true"></a>
        </div>
        <script>
            (function (jQuery, $) {
                jQuery('.bd-search-6 .bd-icon-132').on('click', function (e) {
                    e.preventDefault();
                    jQuery('#search-6').submit();
                });
            })(window._$, window._$);
        </script>
    </div>
</form>
    </div>
</div>
	
		<div class=" bd-layoutbox-5 bd-no-margins bd-no-margins clearfix">
    <div class="bd-container-inner">
                    
        <nav class=" bd-hmenu-1"  data-responsive-menu="true" data-responsive-levels="expand on click" data-responsive-type="offcanvas" data-offcanvas-delay="0ms" data-offcanvas-duration="700ms" data-offcanvas-timing-function="ease">
                        
                <div class=" bd-menuoverlay-17 bd-menu-overlay"></div>
                <div class=" bd-responsivemenu-11 collapse-button">
    <div class="bd-container-inner">
        <div class="bd-menuitem-13 ">
            <a  data-toggle="collapse"
                data-target=".bd-hmenu-1 .collapse-button + .navbar-collapse"
                href="#" onclick="return false;">
                    <span>Prime News Ghana</span>
            </a>
        </div>
    </div>
</div>
                <div class="navbar-collapse collapse width">
            <div class=" bd-horizontalmenu-1 clearfix">
    <div class="bd-container-inner">
        
                
<ul class=" bd-menu-1 nav navbar-left nav-pills"  id="Ghana News Menu">
                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-101 ">
<a title="News in ghana" href="https://www.primenewsghana.com/"><span>Home</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-104 ">
<a title="Top ghana news headlines" href="/general-news.html"><span>General News</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-106  current">
<a class="  active" title="Ghana Political News" href="/politics.html"><span>Politics</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-761 ">
<a class=" local_news_ghana" title="Top ghana news headlines" href="https://www.primenewsghana.com/ghana-news-updates.html"><span>Ghana News Updates</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-188 ">
<a title="Business news" href="/business.html"><span>Business</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-111 ">
<a title="Today's World News covering, Africa, Europe, Middle East" href="/world.html"><span>World</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-107 ">
<a title="Sports news" href="/sports.html"><span>Sports</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-108 ">
<a class=" ghana entertainment news" title="Entertainment news in Ghana and Celebrity news" href="/entertainment.html"><span>Entertainment</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-109 ">
<a title="Lifestyle - Health - Relationships Articles and More" href="/lifestyle.html"><span>Lifestyle</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-103 ">
<a title="Ghana Features and Opinion Articles" href="/features.html"><span>Features </span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-477 ">
<a title="Short Stories on Primenewsghana.com" href="/short-stories.html"><span>Short Stories</span></a></li>                        
        <li class=" bd-menuitem-1 bd-toplevel-item  item-326 ">
<a title="Tech News on Prime" href="/tech.html"><span>Tech</span></a></li>                </ul>        
    </div>
</div>                <div class="bd-menu-close-icon">
    <a href="#" class="bd-icon  bd-icon-108"></a>
</div>
            
                </div>
                    </nav>
        
        </div>
</div>
</header>
	
		<div class="bd-containereffect-8 container-effect container ">
<div class="bd-contentlayout-6  bd-sheetstyles-2  bd-no-margins bd-margins" >
    <div class="bd-container-inner">

        <div class="bd-flex-vertical bd-stretch-inner bd-contentlayout-offset">
            
            <div class="bd-flex-horizontal bd-flex-wide bd-no-margins">
                
                <div class="bd-flex-vertical bd-flex-wide bd-no-margins">
                    

                    <div class=" bd-layoutitemsbox-23 bd-flex-wide bd-no-margins">
    <div class=" bd-content-6">
    

<div class=" bd-blog-3 bd-page-width  bd-no-margins "  >
    <div class="bd-container-inner">
    
        <div class=" bd-grid-6 bd-margins">
          <div class="container-fluid">
            <div class="separated-grid row">
                <div class="separated-item-38 col-md-12 ">
                    
                    <div class="bd-griditem-38">
            
        <article class=" bd-article-3">
            <h1 class=" bd-postheader-3"  >
                        <a href="/politics/adu-boahen-cited-for-conflict-of-interest-ahead-of-vetting-tomorrow.html">
                Adu-Boahen cited for conflict of interest ahead of vetting tomorrow            </a>
            </h1>
	
		<div class=" bd-layoutbox-8 bd-page-width  bd-no-margins clearfix">
    <div class="bd-container-inner">
        <div class=" bd-posticondate-4 bd-no-margins">
    <span class=" "><span><time datetime="2021-06-01T16:20:29+00:00" >Date: 01 June 2021</time></span></span>
</div>
	
		<div class=" bd-posticonauthor-5 bd-no-margins">
    <span class=" "><span>By George Nyavor</span></span>
</div>
	
		<div class=" bd-posticoncategory-9 hidden-xs bd-no-margins">
    <span class=" "><span>Category: <span class="bd-post-metadata-category-name" itemprop="genre">Politics</span></span></span>
</div>
	
		    </div>
</div>
	
		<div class=" bd-layoutbox-10 bd-page-width  bd-no-margins bd-no-margins clearfix">
    <div class="bd-container-inner">
        <div class=" bd-postimage-3 bd-no-margins pull-none">
    
            <img src="/images/2021/may/01/Charles-Adu-Boahen.jpg" alt="" class=" bd-imagestyles-7" />
            
    </div>
	
		<div class=" bd-customhtml-3 bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
    <div class="bd-container-inner bd-content-element">
        <div class="sharethis-inline-share-buttons st-center st-has-labels  st-inline-share-buttons st-animated" id="st-1"><div class="st-total st-hidden">
  <span class="st-label"></span>
  <span class="st-shares">
    Shares
  </span>
</div><div class="st-btn st-first" data-network="facebook" style="display: inline-block;">
  <img alt="facebook sharing button" src="https://platform-cdn.sharethis.com/img/facebook.svg" draggable="false">
  <span class="st-label">Share</span>
</div><div class="st-btn" data-network="twitter" style="display: inline-block;">
  <img alt="twitter sharing button" src="https://platform-cdn.sharethis.com/img/twitter.svg" draggable="false">
  <span class="st-label">Tweet</span>
</div><div class="st-btn" data-network="email" style="display: inline-block;">
  <img alt="email sharing button" src="https://platform-cdn.sharethis.com/img/email.svg" draggable="false">
  <span class="st-label">Email</span>
</div><div class="st-btn st-last" data-network="sharethis" style="display: inline-block;">
  <img alt="sharethis sharing button" src="https://platform-cdn.sharethis.com/img/sharethis.svg" draggable="false">
  <span class="st-label">Share</span>
</div></div>    </div>
</div>
	
		<div class=" bd-postcontent-3 bd-tagstyles bd-custom-blockquotes bd-custom-image bd-custom-bulletlist bd-custom-orderedlist bd-custom-table bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed bd-contentlayout-offset"  >
    <h2>Deputy Ranking Member on Parliament’s Finance Committee, Isaac Adongo, has cited Minister of State-designate at the Finance Ministry, Dr Charles Adu Boahen, for being in a conflict-of-interest situation that makes him unfit for the job.</h2>
 
<p>The opposition National Democratic Congress (NDC) legislator for Bolgatanga Central said Dr Charles Adu-Boahen’s company Black Stars Brokerage is one of two companies currently hired as transaction advisors and book-runners for government loans.</p><div class="inread" align="center">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-5493363406145616"
     data-ad-slot="3282824291"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>He has called on the President’s appointee to withdraw his company’s dealing with the government before his vetting tomorrow, June 2, 2021, or risk rejection.</p>
<p>“They are paid 0.35 per cent per value, that gives you GHS875 million in fees that Databank [owned partly by Finance Minister, Ken Ofori-Atta] and the rest have had to share from the people of Ghana. This year, the government’s total gross financing requirement is about GHS60 billion, again you can offset about GHS10 billion of that for other financing arrangement and treasury bills in the gross financing arrangement, and you have another close to GHS50 billion that would be borrowed by Ken Ofori Atta and his company and Charles Adu-Boahen and his company. In all, we expect payment of GHS210 million in fees and changes to be shared by these book-runners,” he told the media in Parliament on Tuesday.</p><div class="inread" align="center">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-5493363406145616"
     data-ad-slot="3282824291"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>Mr Adongo wants both New Patriotic Party (NPP) and NDC legislators to withdraw those companies immediately, as a matter of conscience.</p>
<p>“I am going to the extent of petitioning the IMF, the World Bank, I will petition the international investment committee and I will petition CHRAJ to look into this. I will make their issuance of bonds a murky business in 2021,” he vowed.</p>
<p>He added: “Only recently you would have seen that the Bank of Ghana has reported very alarming figures for our national public debt. And that figure that was reported by the Bank of Ghana excludes the three billion dollars that we recently borrowed. Even if we are to use one billion of that to refund maturing debts or to call back other bonds that were issued, our public debt portfolios would now be in the region of three hundred and twenty billion. That means that in a little of over four years we’ve added about two hundred billion to our public debt.”</p><div class="inread" align="center">
<!-- Primenewsghana 336 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-5493363406145616"
     data-ad-slot="9610866910"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>He said it is becoming very clear that the phenomenal growth in our public debt is “influenced largely by some people at the Ministry of Finance who have made borrowing their private business because they benefit directly through their companies when Ghana borrows.”</p>
<p>“So, we are no one having to borrow because Ghana needs it, but we have to borrow because their businesses need that money in order for them to be rich. Only recently you would have noticed that the Bank of Ghana released a notice of the companies that have been contracted to be the book runners or the transactional advisors to the Ministry of Finance.”</p>
<p>He maintained “one would think that those companies were contracted by Bank of Ghana, no, they were contracted by the ministry of finance.</p>
<p>“And so Ken Ofori Atta as the minister for finance and Charles Adu-Boahen who until recently when the minister for finance returned from his sick leave was the presidents’ representative at the ministry of finance and has been nominated as a minister of state at the ministry of finance has his company as one of the transactional advisors.”</p></div>
	
		    </div>
</div>
        </article>
        <div class="bd-container-inner"></div>
        
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>
</div>

</div>
</div>

                    
                         </div>
                
                     <aside class="bd-sidebararea-2-column  bd-flex-vertical bd-flex-fixed ">
                <div class="bd-sidebararea-2 bd-flex-wide  bd-margins">
                    
                    <div class=" bd-joomlaposition-49 clearfix" >
            <div class=" bd-block-42 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        

<div class="custom"  >
	<p><a title="Dubai Tour" href="https://eyalitours.com/product/dubai-tour/" target="_blank" rel="noopener noreferrer"><img style="display: block; margin-left: auto; margin-right: auto;" src="/images/eyalitours.jpeg" /></a></p></div>
    </div>
    
</div>
        <div class=" bd-block-42 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" defer></script>
<!-- Primenewsghana 336 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-5493363406145616"
     data-ad-slot="9610866910"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>    </div>
    
</div>
        <div class=" bd-block-42 bd-own-margins default-gray thumb-2x" >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <h4>News Headlines</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        
<div class="allmode-box allmode-default default-gray thumb-2x">




<div class="allmode-itemsbox">

		<article class="allmode-item allmode-category-id14">

				<div class="allmode-img"><a href="/general-news/akufo-addo-commends-media-for-role-in-covid-19-fight.html"><img src="/images/raxo_thumbs/amp/tb-w140-h100-crop-int-50f5f57afc2d52a7fa9a335b0c8e05b4.jpg" width="140" height="100" title="Akufo-Addo commends media for role in COVID-19 fight" alt="" /></a></div>
		
		
				<h4 class="allmode-title"><a href="/general-news/akufo-addo-commends-media-for-role-in-covid-19-fight.html">Akufo-Addo commends media for role in COVID-19 fight</a></h4>
		
		
				<div class="allmode-text">President Nana Addo Dankwa Akufo-Addo has commended the media for its role in&hellip;
			
		</div>
		
	</article>
		<article class="allmode-item allmode-category-id20 allmode-featured">

				<div class="allmode-img"><a href="/business/exxon-exits-oil-exploration-prospect-in-ghana-after-seismic-work.html"><img src="/images/raxo_thumbs/amp/tb-w140-h100-crop-int-1650d0d017e9163b64595931a3df49cc.jpg" width="140" height="100" title="Exxon Exits Oil Exploration Prospect in Ghana After Seismic Work" alt="" /></a></div>
		
		
				<h4 class="allmode-title"><a href="/business/exxon-exits-oil-exploration-prospect-in-ghana-after-seismic-work.html">Exxon Exits Oil Exploration Prospect in Ghana After Seismic Work</a></h4>
		
		
				<div class="allmode-text">Exxon Mobil Corp. is pulling out of a deep-water oil prospect in Ghana just two&hellip;
			
		</div>
		
	</article>
		<article class="allmode-item allmode-category-id24">

				<div class="allmode-img"><a href="/sports/christian-atsu-announces-newcastle-united-departure-after-5years.html"><img src="/images/raxo_thumbs/amp/tb-w140-h100-crop-int-7a447c26e7c99599c89662344c1239b0.jpg" width="140" height="100" title="Christian Atsu announces Newcastle United departure after 5years" alt="Christian Atsu " /></a></div>
		
		
				<h4 class="allmode-title"><a href="/sports/christian-atsu-announces-newcastle-united-departure-after-5years.html">Christian Atsu announces Newcastle United departure after 5years</a></h4>
		
		
				<div class="allmode-text">Ghana international Christain Atsu in a post has announced his exit from&hellip;
			
		</div>
		
	</article>
		<article class="allmode-item allmode-category-id20 allmode-featured">

				<div class="allmode-img"><a href="/business/creditors-right-to-the-payment-of-debt-and-the-limited-liability-feature-of-a-company-limited-by-shares.html"><img src="/images/raxo_thumbs/amp/tb-w140-h100-crop-int-359bd36b71ae86a74796322cd674ae2f.jpg" width="140" height="100" title="Creditors' right to the payment of debt and the limited liability feature of a company limited by shares " alt="" /></a></div>
		
		
				<h4 class="allmode-title"><a href="/business/creditors-right-to-the-payment-of-debt-and-the-limited-liability-feature-of-a-company-limited-by-shares.html">Creditors' right to the payment of debt and the limited liability feature of a company limited by shares </a></h4>
		
		
				<div class="allmode-text">INTRODUCTION A company limited by shares construct produces an entity bestowed&hellip;
			
		</div>
		
	</article>
		<article class="allmode-item allmode-category-id24">

				<div class="allmode-img"><a href="/sports/u-20-afcon-best-player-abdul-fatawu-issahaku-completes-move-to-liverpool.html"><img src="/images/raxo_thumbs/amp/tb-w140-h100-crop-int-0fd646d1bbf45ed974bba5070f6b0304.jpg" width="140" height="100" title="U-20 AFCON best player Abdul Fatawu Issahaku completes move to Liverpool" alt="" /></a></div>
		
		
				<h4 class="allmode-title"><a href="/sports/u-20-afcon-best-player-abdul-fatawu-issahaku-completes-move-to-liverpool.html">U-20 AFCON best player Abdul Fatawu Issahaku completes move to Liverpool</a></h4>
		
		
				<div class="allmode-text">Ghana U-20 star Abdul Fatawu Issahaku has completed a move to Liverpool&hellip;
			
		</div>
		
	</article>
		<article class="allmode-item allmode-category-id13">

				<div class="allmode-img"><a href="/world/viewpoint-why-germany-s-namibia-genocide-apology-is-not-enough.html"><img src="/images/raxo_thumbs/amp/tb-w140-h100-crop-int-75483e00eab9b86f16e5949ce3afb596.jpg" width="140" height="100" title="Viewpoint: Why Germany's Namibia genocide apology is not enough" alt="Between 1904 and 1908 tens of thousands of Herero and Nama people were murdered" /></a></div>
		
		
				<h4 class="allmode-title"><a href="/world/viewpoint-why-germany-s-namibia-genocide-apology-is-not-enough.html">Viewpoint: Why Germany's Namibia genocide apology is not enough</a></h4>
		
		
				<div class="allmode-text">Germany's long-awaited apology for last century's mass killing in Namibia has&hellip;
			
		</div>
		
	</article>
		<article class="allmode-item allmode-category-id14">

				<div class="allmode-img"><a href="/general-news/lab-scientists-call-off-nationwide-strike-after-one-week.html"><img src="/images/raxo_thumbs/amp/tb-w140-h100-crop-int-f0786a69792618be529f7cd0d709cec9.jpg" width="140" height="100" title="Lab Scientists call off nationwide strike after one week" alt="" /></a></div>
		
		
				<h4 class="allmode-title"><a href="/general-news/lab-scientists-call-off-nationwide-strike-after-one-week.html">Lab Scientists call off nationwide strike after one week</a></h4>
		
		
				<div class="allmode-text">Lab scientists across the country say they have resumed work from today June 1,&hellip;
			
		</div>
		
	</article>
		<article class="allmode-item allmode-category-id14 allmode-featured">

				<div class="allmode-img"><a href="/general-news/we-disagree-achimota-appeals-court-ruling-to-admit-rasta-students.html"><img src="/images/raxo_thumbs/amp/tb-w140-h100-crop-int-7ad2db6e7f01b9aa4e18fe0b32cafd6f.jpg" width="140" height="100" title="We disagree! Achimota School to appeal ruling to admit Rasta students" alt="" /></a></div>
		
		
				<h4 class="allmode-title"><a href="/general-news/we-disagree-achimota-appeals-court-ruling-to-admit-rasta-students.html">We disagree! Achimota School to appeal ruling to admit Rasta students</a></h4>
		
		
				<div class="allmode-text">Achimota Secondary School has released a statement stating its explicit&hellip;
			
		</div>
		
	</article>
		<article class="allmode-item allmode-category-id14">

				<div class="allmode-img"><a href="/general-news/pci-an-ngo-to-support-pastors-and-their-families-in-the-rural-and-deprived-communities-launched.html"><img src="/images/raxo_thumbs/amp/tb-w140-h100-crop-int-31bb172c8b49fb916fb9ab49ca4c006a.jpg" width="140" height="100" title="PCI: An NGO to support Pastors and their families in the rural and deprived communities launched" alt="" /></a></div>
		
		
				<h4 class="allmode-title"><a href="/general-news/pci-an-ngo-to-support-pastors-and-their-families-in-the-rural-and-deprived-communities-launched.html">PCI: An NGO to support Pastors and their families in the rural and deprived communities launched</a></h4>
		
		
				<div class="allmode-text">Pastors Care Initiative, known as PCI for short, is an initiative founded by&hellip;
			
		</div>
		
	</article>
		<article class="allmode-item allmode-category-id14 allmode-featured">

				<div class="allmode-img"><a href="/general-news/ghanaians-jubilate-over-achimota-school-s-defeat-against-dreadlocked-students.html"><img src="/images/raxo_thumbs/amp/tb-w140-h100-crop-int-430454f6d4961e0fb023d0807de9ffcd.jpg" width="140" height="100" title="Ghanaians jubilate over Achimota School’s court defeat by Rasta students" alt="" /></a></div>
		
		
				<h4 class="allmode-title"><a href="/general-news/ghanaians-jubilate-over-achimota-school-s-defeat-against-dreadlocked-students.html">Ghanaians jubilate over Achimota School’s court defeat by Rasta students</a></h4>
		
		
				<div class="allmode-text">Ghanaians have taken to social media to express their excitement over a court&hellip;
			
		</div>
		
	</article>
	
</div>
</div>
    </div>
    
</div>
        <div class=" bd-block-42 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <div id="taboola-right-rail-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-rr',
    container: 'taboola-right-rail-thumbnails',
    placement: 'Right Rail Thumbnails',
    target_type: 'mix'
  });
</script>    </div>
    
</div>
        </div>
        	
		    
        <div class=" bd-joomlaposition-61 clearfix" >
            <div class=" bd-block-73 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <!-- 336 Artcile Bottom -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-5510276167635361"
     data-ad-slot="9768827792"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>    </div>
    
</div>
        </div>                    
                </div>
            </aside>
                    </div>
            
        </div>

    </div>
</div></div>
	
		<footer class=" bd-footerarea-1 bd-textureoverlay bd-textureoverlay-1 bd-margins">
        <section class=" bd-section-2 bd-tagstyles bd-custom-bulletlist bd-custom-orderedlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed" id="footersection" data-section-title="Footer With Links">
    <div class="bd-container-inner bd-margins clearfix">
        <div class=" bd-layoutbox-9 bd-no-margins bd-no-margins clearfix">
    <div class="bd-container-inner">
        <div class=" bd-spacer-2 clearfix"></div>
	
		<div class=" bd-layoutcontainer-17 bd-columns bd-no-margins">
    <div class="bd-container-inner">
        <div class="container-fluid">
            <div class="row ">
                <div class=" bd-columnwrapper-24 
 col-lg-3
 col-sm-3">
    <div class="bd-layoutcolumn-24 bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-27 hidden-xs clearfix" >
            <div class=" bd-block-34 bd-own-margins " >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <h4>News Sections</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ul class=""><li class="item-176 active"><a title="Politics in ghana" href="/politics.html"><span>Politics</span></a></li><li class="item-177"><a title="local general news" href="/general-news.html"><span>General News</span></a></li><li class="item-178"><a title="Lifestyle articles" href="/lifestyle.html"><span>Lifestyle</span></a></li><li class="item-179"><a title="Celebrity news in Ghana" href="/entertainment.html"><span>Entertainment</span></a></li></ul>    </div>
    
</div>
        </div>
        </div></div>
</div>
	
		<div class=" bd-columnwrapper-23 
 col-lg-2
 col-sm-3">
    <div class="bd-layoutcolumn-23 bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-24 hidden-xs clearfix" >
            <div class=" bd-block-36 bd-own-margins " >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <h4>More News Section</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ul class=""><li class="item-304"><a title="African News Headlines" href="/africa.html"><span>Africa</span></a></li><li class="item-180"><a href="/tech.html"><span>Science/Tech</span></a></li><li class="item-181"><a title="Your opinion articles and features" href="/features.html"><span>Opinion</span></a></li><li class="item-182"><a title="World and International News" href="/world.html"><span>World News</span></a></li><li class="item-187"><a title="Business and Financial news" href="/business.html"><span>Business News</span></a></li></ul>    </div>
    
</div>
        </div>
        </div></div>
</div>
	
		<div class=" bd-columnwrapper-60 
 col-lg-2
 col-sm-3">
    <div class="bd-layoutcolumn-60 bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-32 hidden-xs clearfix" >
            <div class=" bd-block-161 bd-own-margins " >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <h4>About Us</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
        <ul class=""><li class="item-185"><a title="Meet The Team" href="/meet-the-team.html"><span>Meet The Team</span></a></li><li class="item-184"><a href="/about-primenews.html"><span>About PrimeNews</span></a></li><li class="item-183"><a href="/terms-conditions.html"><span>Terms &amp; Conditions</span></a></li><li class="item-757"><a href="/privacy-policy.html"><span>Privacy Policy</span></a></li><li class="item-203"><a href="/search-ghana-news.html"><span>Search Page</span></a></li><li class="item-282"><a title="Prime news ghana sitemap" href="https://www.primenewsghana.com/index.php?option=com_jmap&amp;view=sitemap&amp;format=xml&amp;xslt=1"><span>Sitemap</span></a></li></ul>    </div>
    
</div>
        </div>
        </div></div>
</div>
	
		<div class=" bd-columnwrapper-22 
 col-lg-5
 col-sm-3">
    <div class="bd-layoutcolumn-22 bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-10 clearfix" >
            </div>
        </div></div>
</div>
            </div>
        </div>
    </div>
</div>
	
		    
        <div class=" bd-joomlaposition-28 bd-no-margins clearfix" >
            <div class=" bd-block-174 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-custom-blockquotes bd-custom-bulletlist bd-bootstrap-tables bd-table-striped bd-table-hover bd-table-condensed">
         &copy; 2016 - 2021. All Rights Reserved - Primenewsghana.com.    </div>
    
</div>
        </div>
            </div>
</div>
    </div>
</section>
</footer>
	
		<div class="bd-containereffect-24 container-effect container ">
</div>
</body>
</html>