<!DOCTYPE html>
<html lang="en-gb" dir="ltr">
<head>
    <base href="https://www.primenewsghana.com/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.html" />    <link href="https://www.primenewsghana.com/templates/primetakebk/images/designer/62cf4d06d7c31cfa0ac859e95b15f9c2_favicon96x96.png" rel="icon" type="image/x-icon" />
    <script>
    var themeHasJQuery = !!window.jQuery;
</script>
<script src="/templates/primetakebk/jquery.js?version=1.0.1309"></script>
<script>
    window._$ = jQuery.noConflict(themeHasJQuery);
</script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
<script src="/templates/primetakebk/bootstrap.min.js?version=1.0.1309"></script>
<!--[if lte IE 9]>
<script src="/templates/primetakebk/layout.ie.js?version=1.0.1309"></script>
<link rel="stylesheet" href="/templates/primetakebk/layout.ie.css?version=1.0.1309" media="screen"/>
<![endif]-->
<link class="" href='//fonts.googleapis.com/css?family=Ubuntu:300,300italic,regular,italic,500,500italic,700,700italic|Roboto:100,100italic,300,300italic,regular,italic,500,500italic,700,700italic,900,900italic|Roboto+Condensed:300,300italic,regular,italic,700,700italic|Actor:regular&subset=latin' rel='stylesheet' type='text/css'>
<script src="/templates/primetakebk/layout.core.js?version=1.0.1309"></script>
    
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
	<meta name="keywords" content="Ghanaweb News, Ghana General News, News From Ghana, Crime Reports" />
	<meta name="fb:app_id" content="1396450703736402" />
	<meta name="fb:admins" content="desmond.bruce1" />
		<meta name="author" content="Wendy Amarteifio" />
	<meta name="canonical" content="https://www.primenewsghana.com/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.html" />
	<meta name="description" content="The leaders are to hold an emergency  meeting   to development  road map for the impending  protest.
" />
	<title>KNUST Students to demonstrate today after Colleagues’ arrest  - Prime News Ghana</title>
	<link href="https://www.primenewsghana.com/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.amp.html" rel="amphtml" />
	<link href="https://www.primenewsghana.com/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.html" rel="canonical" />
	<link href="/modules/mod_raxo_allmode/tmpl/allmode-list/allmode-list.15thfeb.css" rel="stylesheet" type="text/css" />
	<meta property="og:title" content="KNUST Students to demonstrate today after Colleagues’ arrest " />
	<meta property="og:type" content="article" />
	<meta property="og:image" content="https://www.primenewsghana.com/images/2018/oct/22/knust-logo.jpg" />
	<meta property="og:url" content="https://www.primenewsghana.com/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.html" />
	<meta property="og:site_name" content="Primenewsghana.com" />
	<meta property="og:description" content="The leaders are to hold an emergency  meeting   to development  road map for the impending  protest.
" />
	<meta property="fb:app_id" content="946493835400498" />
	<!-- Start: Google Structured Data -->
             <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "WebSite", "url": "https://www.primenewsghana.com", "potentialAction": { "@type": "SearchAction", "target": "https://www.primenewsghana.com/index.php?option=com_search&searchphrase=all&searchword={search_term}", "query-input": "required name=search_term" } } </script> <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "Organization", "url": "https://www.primenewsghana.com", "logo": "https://www.primenewsghana.com/images/2016/Dec/PRIMENEWS_LOGO.png" } </script> <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "Organization", "name": "Primenewsghana.com", "url": "https://www.primenewsghana.com", "sameAs": [ "https://www.facebook.com/primenewsghana", "https://twitter.com/primenewsghana", "https://plus.google.com/+Primenewsghana", "https://www.instagram.com/primenewsghana", "https://www.youtube.com/channel/UCwTOjDp8yL7PYcicNX0XZXg" ] } </script> <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "LocalBusiness", "@id": "https://www.primenewsghana.com", "name": "Primenewsghana.com", "image": "https://www.primenewsghana.com/images/2016/Dec/PRIMENEWS_LOGO.png", "url": "https://www.primenewsghana.com", "telephone": 233302230696, "priceRange": 0, "address": { "@type": "PostalAddress", "streetAddress": null, "addressLocality": "Asylum Down, Accra", "addressRegion": "Greater Accra", "postalCode": 23321, "addressCountry": "GH" }, "geo": { "@type": "GeoCoordinates", "latitude": 5.56905062242598258848147452226839959621429443359375, "longitude": -0.206227540838881395757198333740234375 }, "openingHoursSpecification": { "@type": "OpeningHoursSpecification", "dayOfWeek": [ "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday", "Sunday" ], "opens": "00:00", "closes": "23:59" } } </script> <script type="application/ld+json"> { "@context": "https://schema.org", "@type": "BreadcrumbList", "itemListElement": [ { "@type": "ListItem", "position": 1, "item": { "@id": "https://www.primenewsghana.com/", "name": "HomePage" } }, { "@type": "ListItem", "position": 2, "item": { "@id": "https://www.primenewsghana.com/general-news.html", "name": "News" } }, { "@type": "ListItem", "position": 3, "item": { "@id": "https://www.primenewsghana.com/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.html", "name": "KNUST Students to demonstrate today after Colleagues’ arrest" } } ] } </script>
            <!-- End: Google Structured Data -->
	<meta property="article:publisher" content="https://www.facebook.com/primenewsghana" />
<meta property="og:site_name" content="PrimeNewsGhana.com">
<meta property="twitter:site" content="@primenewsghana">
<meta property="og:locale" content="en-GB">
<meta name="theme-color" content="#f92306">
<meta property="fb:pages" content="1715906461955288" />
<meta property="og:image:width" content="600"/>
<meta property="og:image:height" content="400"/>
<meta http-equiv="refresh" content="900"/>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-78977309-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-78977309-1');
</script>

<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"q5Nao1IW1810vg", domain:"primenewsghana.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=q5Nao1IW1810vg" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->  
<link href="https://platform-api.sharethis.com/js/sharethis.js/" rel="dns-prefetch"> 
<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '2223560921263475');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=2223560921263475&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->
        <link rel="stylesheet" href="/templates/primetakebk/css/bootstrap.min.css?version=1.0.1309" media="screen" />
            <link rel="stylesheet" href="/templates/primetakebk/css/template.min.css?version=1.0.1309" media="screen" />
            <script src="/templates/primetakebk/script.js?version=1.0.1309"></script>
    <!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PX48M8M');</script>
<!-- End Google Tag Manager -->



<!-- Start PushCrew Asynchronous Code -->
<script type='text/javascript'>
(function(p,u,s,h) {
    p._pcq = p._pcq || [];
    p._pcq.push(['_currentTime', Date.now()]);
    s = u.createElement('script'); s.type = 'text/javascript'; s.async = true;
    s.src = 'https://cdn.pushcrew.com/js/d45052056e2022531a29c90b6a088e90.js';
    h = u.getElementsByTagName('script')[0]; h.parentNode.insertBefore(s, h);
})(window,document);
</script>
<!-- End PushCrew Asynchronous Code -->


</head>
<body class=" bootstrap bd-body-3  bd-pagebackground-32 bd-margins">
    <header class=" bd-headerarea-1 bd-margins">
        <div class="bd-containereffect-6 container-effect container "><div class=" bd-customhtml-2 bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed ">
    <div class="bd-container-inner bd-content-element">
        <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PX48M8M" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<script> window.fbAsyncInit = function() { FB.init({ appId : '1396450703736402', xfbml : true, version : 'v2.10' }); FB.AppEvents.logPageView(); }; (function(d, s, id){ var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) {return;} js = d.createElement(s); js.id = id; js.src = "//connect.facebook.net/en_US/sdk.js"; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>    </div>
</div></div>
	
		<div class="bd-containereffect-9 container-effect container "><div class=" bd-layoutbox-1 hidden-xs  bd-no-margins clearfix">
    <div class="bd-container-inner">
                    
        <div class=" bd-topmenu-1 hidden-xs" data-responsive-menu="true">
                        
                <div class=" bd-responsivemenu-1 collapse-button">
    <div class="bd-container-inner">
        <div class="bd-menuitem-3 ">
            <a  data-toggle="collapse"
                data-target=".bd-topmenu-1 .collapse-button + .navbar-collapse"
                href="#" onclick="return false;">
                    <span></span>
            </a>
        </div>
    </div>
</div>
                <div class="navbar-collapse collapse">
                <div class=" bd-horizontalmenu-2 clearfix">
                    <div class="bd-container-inner">
                        <ul class=" bd-menu-3 nav nav-pills navbar-left" >
<li class=" bd-menuitem-4 item-203">
<a href="/"><span>Home</span></a></li><li class=" bd-menuitem-4 item-206">
<a href="/contact-us-2.html"><span>Contact Us</span></a></li><li class=" bd-menuitem-4 item-374">
<a href="/election-2016.html"><span>Election 2016</span></a></li></ul>                    </div>
                </div>
            
                </div>
                    </div>
        
    	
		        	
		<div class=" bd-layoutcontainer-11 bd-columns bd-no-margins">
    <div class="bd-container-inner">
        <div class="container-fluid">
            <div class="row ">
                <div class=" bd-columnwrapper-25 
 col-sm-12">
    <div class="bd-layoutcolumn-25 bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-13 clearfix" >
            <div class=" bd-block-15 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        

<div class="custom"  >
	<p>CALL US : +233 0302 230 696 Email: info@primenewsghana.com</p></div>
    </div>
    
</div>
        </div>
        </div></div>
</div>
            </div>
        </div>
    </div>
</div>
    </div>
</div>
</div>
	
		<div class="bd-containereffect-21 container-effect container "><div class=" bd-layoutbox-4  bd-no-margins clearfix">
    <div class="bd-container-inner">
        <a class=" bd-logo-3 hidden-sm hidden-xs" href="https://www.primenewsghana.com">
<img class=" bd-imagestyles" src="https://www.primenewsghana.com/images/siteimages/NEW-PRIME-LOGO_small.png" alt="Prime News Ghana">
</a>
	
		<a class=" bd-logo-2 hidden-md hidden-lg" href="https://www.primenewsghana.com">
<img class=" bd-imagestyles" src="https://www.primenewsghana.com/images/siteimages/NEW-PRIME-LOGO_small.png" alt="Prime News Ghana">
</a>
	
		<form id="search-3" role="form" class=" bd-search-3 hidden-xs bd-no-margins form-inline" name="search" action="/index.php" method="post">
    <div class="bd-container-inner">
        <input type="hidden" name="task" value="search">
        <input type="hidden" name="option" value="com_search">
        <div class="bd-search-wrapper">
            
                <input type="text" name="searchword" class=" bd-bootstrapinput-9 form-control" placeholder="Search Here">
                <a href="#" class="bd-icon-4 bd-icon " link-disable="true"></a>
        </div>
        <script>
            (function (jQuery, $) {
                jQuery('.bd-search-3 .bd-icon-4').on('click', function (e) {
                    e.preventDefault();
                    jQuery('#search-3').submit();
                });
            })(window._$, window._$);
        </script>
    </div>
</form>
	
		<form id="search-10" role="form" class=" bd-search-10 hidden-md hidden-sm hidden-lg form-inline" name="search" action="/index.php" method="post">
    <div class="bd-container-inner">
        <input type="hidden" name="task" value="search">
        <input type="hidden" name="option" value="com_search">
        <div class="bd-search-wrapper">
            
                <input type="text" name="searchword" class=" bd-bootstrapinput-6 form-control input-sm" placeholder="Search">
                <a href="#" class="bd-icon-13 bd-icon " link-disable="true"></a>
        </div>
        <script>
            (function (jQuery, $) {
                jQuery('.bd-search-10 .bd-icon-13').on('click', function (e) {
                    e.preventDefault();
                    jQuery('#search-10').submit();
                });
            })(window._$, window._$);
        </script>
    </div>
</form>
	
		<h2 class=" bd-textblock-3 hidden-xs bd-content-element">
    Prime News Ghana<br></h2>
	
		<p class=" bd-textblock-2 hidden-xs bd-content-element">
    News. When Its New...</p>
    </div>
</div>
</div>
	
		<div class="bd-containereffect-22 container-effect container ">
<div data-affix
     data-offset=""
     data-fix-at-screen="top"
     data-clip-at-control="top"
     
 data-enable-lg
     
 data-enable-md
     
 data-enable-sm
     
     class=" bd-affix-1 bd-no-margins bd-margins "><div class=" bd-layoutbox-5   bd-no-margins clearfix">
    <div class="bd-container-inner">
                    
        <nav class=" bd-hmenu-1"  data-responsive-menu="true" data-responsive-levels="expand on click" data-responsive-type="" data-close-icon="bd-icon-27" data-offcanvas-delay="0ms" data-offcanvas-duration="700ms" data-offcanvas-timing-function="ease">
                        
                <div class=" bd-responsivemenu-11 collapse-button">
    <div class="bd-container-inner">
        <div class="bd-menuitem-10 ">
            <a  data-toggle="collapse"
                data-target=".bd-hmenu-1 .collapse-button + .navbar-collapse"
                href="#" onclick="return false;">
                    <span>Prime News Ghana</span>
            </a>
        </div>
    </div>
</div>
                <div class="navbar-collapse collapse ">
            <div class=" bd-horizontalmenu-6 clearfix">
    <div class="bd-container-inner">
                
<ul class=" bd-menu-11 nav navbar-left nav-pills" >
                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-101 ">
<a title="Ghana News, news in Ghana, Prime news top stories" href="/"><span>Home</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-104  current">
<a class="  active" title="Ghana News on Primenewsghana" href="/general-news.html"><span>News</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-106 ">
<a title="Ghana Political news" href="/politics.html"><span>Politics</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-188 ">
<a title="Ghana Business, Economic and Financial News" href="/business.html"><span>Primebusiness</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-111 ">
<a title="Today's Prime World, Africa, Europe, Middle East" href="/world.html"><span>World</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-107 ">
<a title="Sports news" href="/sports.html"><span>Sports</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-108 ">
<a title="Primenews Ghana Entertainment and Showbiz" href="/entertainment.html"><span>Entertainment</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-109 ">
<a title="Lifestyle - Health - Relationships Articles and More" href="/lifestyle.html"><span>Lifestyle</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-103 ">
<a title="Ghana Features and Opinion Articles" href="/features.html"><span>Features </span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-477 ">
<a title="Short Stories on Primenewsghana.com" href="/short-stories.html"><span>Short Stories</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-326 ">
<a href="/tech.html"><span>Tech</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-443 ">
<a href="/gossip-bizzare.html"><span>Gossip</span></a></li>                        
        <li class=" bd-menuitem-20 bd-toplevel-item  item-506 ">
<a href="/opinion.html"><span>Opinion</span></a></li>                </ul>    </div>
</div>                <div class=" bd-menuoverlay-20 bd-menu-overlay"></div>
            
                </div>
                    </nav>
        
        </div>
</div>
</div>
</div>
</header>
	
		<div class="bd-containereffect-14 container-effect container ">    
        <div class=" bd-joomlaposition-2  clearfix" >
            <div class=" bd-block-37 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <div class="bannergroup">

	<div class="banneritem">
										<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Prime News Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5493363406145616"
     data-ad-slot="5980868087"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>				<div class="clr"></div>
	</div>

</div>
    </div>
    
</div>
        </div>
        </div>
	
		<div class="bd-containereffect-31 container-effect container ">
<div class="bd-contentlayout-1  bd-sheetstyles-4  bd-no-margins bd-margins" >
    <div class="bd-container-inner">

        <div class="bd-flex-vertical bd-stretch-inner bd-contentlayout-offset">
            
            <div class="bd-flex-horizontal bd-flex-wide bd-no-margins">
                
                <div class="bd-flex-vertical bd-flex-wide bd-no-margins">
                    

                    <div class=" bd-layoutitemsbox-1 bd-flex-wide bd-no-margins">
    <div class=" bd-content-10">
    

<div class=" bd-blog-3 " itemscope itemtype="http://schema.org/Article" >
    <div class="bd-container-inner">
    
        <div class=" bd-grid-6 bd-margins">
          <div class="container-fluid">
            <div class="separated-grid row">
                <div class="separated-item-38 col-md-12 ">
                    
                    <div class="bd-griditem-38">
            
        <article class=" bd-article-3">
            <h1 class=" bd-postheader-3"  itemprop="name">
                        <a href="/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.html">
                KNUST Students to demonstrate today after Colleagues’ arrest             </a>
            </h1>
	
		<div class=" bd-layoutbox-8 bd-no-margins clearfix">
    <div class="bd-container-inner">
        <div class=" bd-posticondate-4 bd-no-margins">
    <span class=" bd-icon bd-icon-41"><span><time datetime="2018-10-22T09:41:26+00:00" itemprop="datePublished">Date: 22 October 2018</time></span></span>
</div>
	
		<div class=" bd-posticonauthor-5 bd-no-margins">
    <span class=" bd-icon bd-icon-43"><span>By Wendy Amarteifio</span></span>
</div>
	
			
			
		<div class=" bd-posticoncategory-9 hidden-xs">
    <span class=" "><span>Category: <span class="bd-post-metadata-category-name"><a href="/general-news.html" itemprop="genre">general news</a></span></span></span>
</div>
    </div>
</div>
	
		<div class=" bd-layoutbox-10 bd-no-margins clearfix">
    <div class="bd-container-inner">
        <div class=" bd-postimage-3 bd-no-margins pull-none">
    
            <img src="/images/2018/oct/22/knust-logo.jpg" alt="KNUST students to demonstrate today" class=" bd-imagestyles-7" itemprop="image"/>
            
        <div class=" bd-container-54 bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed ">
        KNUST students have resolved to boycott lectures today     </div>
    </div>
	
		<div class=" bd-postcontent-3 bd-tagstyles bd-custom-blockquotes bd-custom-image bd-custom-table bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-contentlayout-offset"  itemprop="articleBody">
    <h2>The Students’ Representative Council (SRC) of the Kwame Nkrumah University of Science and Technology (KNUST) will today, Monday, October 22, embark on a demonstration over what they say is the continuous unfair treatment meted out to them by the management of the university.</h2>
 
<h3>The leaders are to hold an emergency meeting to develop a roadmap for the protest.</h3>
<h3>The impending protest has been generated by the recent arrest and subsequent release of some students by police in the Ashanti Region.</h3>
<br />Barely a week after management of the University had served notice that it had suspended the organization of vigils, also known as ‘Morales’ in the school, 10 students, and one alumnus, were arrested on Friday while holding a vigil on campus, a development which angered some parents and guardians who accused the authorities of intimidation.<br /><br />In a statement by the executive council of the SRC, it said the demonstration has become necessary to bring an end to what seems to be the neglect on the part of university management.<br /><br />“The KNUST SRC Executive Council in joint forces with SRC parliamentary council and all student leaders bring to the notice of all KNUST students that we are embarking on a demonstration today 22nd October 2018. [There will be no lectures]. We have had enough.”<br /><br />The SRC said the actions of the campus security and the police officers were ‘gross deviation’ because the two agencies were rather to protect them.<br /><br />READ MORE: <a href="/general-news/knust-investigates-3-students-over-attacks-on-security-man.html">KNUST investigates 3 students over attacks on security man</a><br /><br /><br />“It must be made known to the council that students were manhandled and even in some cases brutalized, acts we find condemnable atrocious.”<br /><br />The main student body at KNUST is also promising the student populace of its commitment of ensuring that security officers who manhandled students are brought to book within the remits of the law, hence students should remain calm and those affected by the incident should report to the council for their demands to be met.<br /><br />“We call for calm from all students in the university in the wake of these rather despicable happenings as we seek justice for all affected. As the main representative body of students on campus, we remain poised to exhaust all available channels to make sure all security officers found guilty are duly penalized.”<br /><br />Furthermore, we entreat any student who has been brutalized in any kind of way to bring to our notice their various grievances. Enough is enough, the statement concluded.<br />Management of the Kwame Nkrumah University of Science and Technology (KNUST) has justified the arrest of some students of the University.<br /><br />In an interview with Citi News monitored by<strong> Prime News Ghana</strong>, the University’s Public Relations Officer, Kwame Yeboah, stated that the students did not seek permission before undertaking the activity contrary to the rules of the university.<br /><br />“The university thinks certain activities in the night should not be entertained. Some other activities are permitted because the students applied for permission. But there was no permission for last Friday’s activity. The students decided to go their own way. They decided not to obey any rules or regulations on campus, the law doesn’t permit that. So when it happened, the police were brought in.”<br /><br /><a title="Latest news in Ghana" href="/general-news.html">Ghana News: Latest news in Ghana</a><div id='fb-root'></div>
				<script>(function(d, s, id) {
				  var js, fjs = d.getElementsByTagName(s)[0];
				  if (d.getElementById(id)) return;
				  js = d.createElement(s); js.id = id;
				  js.src = '//connect.facebook.net/en_US/all.js#xfbml=1&appId=1396450703736402';
				  fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));</script>
				
			<div class='fb-comments' data-href='http://www.primenewsghana.com/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.html' data-num-posts='10' data-width='600' ></div></p></div>
    </div>
</div>
        </article>
        <div class="bd-container-inner"><div class=" bd-pager-3">
    <ul class=" bd-pagination-4 pager">
                <li class=" bd-paginationitem-4">
		<a class="hasTooltip" title="Kingsley Karikari-Bondzie is new Dep.CEO of Coastal Dev't Authority" aria-label="Previous article: Kingsley Karikari-Bondzie is new Dep.CEO of Coastal Dev't Authority" href="/general-news/kingsley-karikari-bondzie-is-new-dep-ceo-of-costal-dev-t-authority.html" rel="prev">
			<span class="icon-chevron-left" aria-hidden="true"></span> <span aria-hidden="true">Prev</span>		</a>
	</li>
                        <li class=" bd-paginationitem-4">
		<a class="hasTooltip" title="Tema Motorway traffic diverted again as Roundabout Interchange project continues" aria-label="Next article: Tema Motorway traffic diverted again as Roundabout Interchange project continues" href="/general-news/tema-motorway-traffic-diverted-again-as-roundabout-interchange-project-continues.html" rel="next">
			<span aria-hidden="true">Next</span> <span class="icon-chevron-right" aria-hidden="true"></span>		</a>
	</li>
            </ul>
</div>
</div>
        
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>
</div>

</div>
</div>

                    
                     <aside class="bd-sidebararea-4-column  bd-flex-vertical bd-flex-fixed ">
                <div class="bd-sidebararea-4 bd-flex-wide  bd-margins">
                    
                    <div class=" bd-joomlaposition-14 clearfix" >
            <div class=" bd-block-29 bd-own-margins  visible-lg" >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-5493363406145616"
     data-ad-slot="3106612483"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>    </div>
    
</div>
        <div class=" bd-block-29 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <ins data-revive-zoneid="1" data-revive-id="73b534250917d5bcca73e3109f298dbb"></ins>
<script async src="//ads.primenewsghana.com/www/delivery/asyncjs.php"></script>    </div>
    
</div>
        </div>                    
                </div>
            </aside>
                        </div>
                
                     <aside class="bd-sidebararea-2-column  bd-flex-vertical bd-flex-fixed ">
                <div class="bd-sidebararea-2 bd-flex-wide  bd-contentlayout-offset">
                    
                    <div class="bd-containereffect-27 container-effect container ">    
        <div class=" bd-joomlaposition-22  clearfix" >
            <div class=" bd-block-28 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <ins data-revive-zoneid="6" data-revive-id="73b534250917d5bcca73e3109f298dbb"></ins>
<script async src="//ads.primenewsghana.com/www/delivery/asyncjs.php"></script>    </div>
    
</div>
        <div class=" bd-block-28 bd-own-margins list-red thumb-3x" >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <h4>Prime Headlines</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        
<div class="allmode-box allmode-list list-red thumb-3x">


<ul class="allmode-items">

	

	
		<li class="allmode-item">

						<div class="allmode-img"><a href="/sports/real-madrid-set-to-sack-julen-lopetegui-after-just-12-games.html"><img src="/modules/mod_raxo_allmode/tools/tb.php?src=%2Fimages%2F2018%2Foct%2F22%2F1032279006515_4869549655821.jpg&amp;w=120&amp;h=80&amp;zc=1" width="120" height="80" title="Real Madrid set to sack Julen Lopetegui after just 12 games" alt="Julen Lopetegui" /></a></div>
			
			
			<div class="allmode-right">

								<h3 class="allmode-title"><a href="/sports/real-madrid-set-to-sack-julen-lopetegui-after-just-12-games.html">Real Madrid set to sack Julen Lopetegui after just 12 games</a></h3>
				
				
				
			</div>

			<a href="/sports/real-madrid-set-to-sack-julen-lopetegui-after-just-12-games.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item">

						<div class="allmode-img"><a href="/general-news/several-teachers-on-study-leave-impersonated-at-nss.html"><img src="/modules/mod_raxo_allmode/tools/tb.php?src=%2Fimages%2F2018%2Foct%2F22%2Fmaxresdefault-7.jpg&amp;w=120&amp;h=80&amp;zc=1" width="120" height="80" title="Several teachers on study leave impersonated at NSS" alt="" /></a></div>
			
			
			<div class="allmode-right">

								<h3 class="allmode-title"><a href="/general-news/several-teachers-on-study-leave-impersonated-at-nss.html">Several teachers on study leave impersonated at NSS</a></h3>
				
				
				
			</div>

			<a href="/general-news/several-teachers-on-study-leave-impersonated-at-nss.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item">

						<div class="allmode-img"><a href="/sports/ghana-fa-secretariat-set-to-open-today.html"><img src="/modules/mod_raxo_allmode/tools/tb.php?src=%2Fimages%2F2018%2Foct%2F22%2FGFA-Headoffice.jpg&amp;w=120&amp;h=80&amp;zc=1" width="120" height="80" title="GFA secretariat set to open today" alt="GFA_Headoffice" /></a></div>
			
			
			<div class="allmode-right">

								<h3 class="allmode-title"><a href="/sports/ghana-fa-secretariat-set-to-open-today.html">GFA secretariat set to open today</a></h3>
				
				
				
			</div>

			<a href="/sports/ghana-fa-secretariat-set-to-open-today.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item">

						<div class="allmode-img"><a href="/sports/rooney-scores-again-as-dc-united-reach-play-offs.html"><img src="/modules/mod_raxo_allmode/tools/tb.php?src=%2Fimages%2F2018%2Foct%2F22%2FDqD5dPGVAAA3mpi.jpg&amp;w=120&amp;h=80&amp;zc=1" width="120" height="80" title="Rooney scores again as DC United reach play-offs" alt="Wayne Rooney" /></a></div>
			
			
			<div class="allmode-right">

								<h3 class="allmode-title"><a href="/sports/rooney-scores-again-as-dc-united-reach-play-offs.html">Rooney scores again as DC United reach play-offs</a></h3>
				
				
				
			</div>

			<a href="/sports/rooney-scores-again-as-dc-united-reach-play-offs.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item">

						<div class="allmode-img"><a href="/business/gold-coast-holding-to-stop-issuance-of-fixed-term-guaranteed-returns-to-clients-nduom.html"><img src="/modules/mod_raxo_allmode/tools/tb.php?src=%2Fimages%2F2018%2Foct%2FDr-Papa-Kwesi-Nduom.png&amp;w=120&amp;h=80&amp;zc=1" width="120" height="80" title="Gold Coast Holding to stop issuance of fixed-term guaranteed returns to clients - Nduom" alt="Dr_Papa_Kwesi_Nduom" /></a></div>
			
			
			<div class="allmode-right">

								<h3 class="allmode-title"><a href="/business/gold-coast-holding-to-stop-issuance-of-fixed-term-guaranteed-returns-to-clients-nduom.html">Gold Coast Holding to stop issuance of fixed-term guaranteed returns to clients - Nduom</a></h3>
				
				
				
			</div>

			<a href="/business/gold-coast-holding-to-stop-issuance-of-fixed-term-guaranteed-returns-to-clients-nduom.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item">

						<div class="allmode-img"><a href="/general-news/kingsley-karikari-bondzie-is-new-dep-ceo-of-costal-dev-t-authority.html"><img src="/modules/mod_raxo_allmode/tools/tb.php?src=%2Fimages%2F2018%2Foct%2F22%2Fnew-pic.jpg&amp;w=120&amp;h=80&amp;zc=1" width="120" height="80" title="Kingsley Karikari-Bondzie is new Dep.CEO of Coastal Dev't Authority" alt="kingsley Bondzie_ as new coastal dev't CEO" /></a></div>
			
			
			<div class="allmode-right">

								<h3 class="allmode-title"><a href="/general-news/kingsley-karikari-bondzie-is-new-dep-ceo-of-costal-dev-t-authority.html">Kingsley Karikari-Bondzie is new Dep.CEO of Coastal Dev't Authority</a></h3>
				
				
				
			</div>

			<a href="/general-news/kingsley-karikari-bondzie-is-new-dep-ceo-of-costal-dev-t-authority.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item">

						<div class="allmode-img"><a href="/entertainment/ben-brako-explains-viral-semi-nude-photo-with-wife.html"><img src="/modules/mod_raxo_allmode/tools/tb.php?src=%2Fimages%2F2018%2Foct%2F22%2FBen-Brako.jpg&amp;w=120&amp;h=80&amp;zc=1" width="120" height="80" title="Ben Brako explains viral semi-nude photo with wife" alt="Ben_Brako" /></a></div>
			
			
			<div class="allmode-right">

								<h3 class="allmode-title"><a href="/entertainment/ben-brako-explains-viral-semi-nude-photo-with-wife.html">Ben Brako explains viral semi-nude photo with wife</a></h3>
				
				
				
			</div>

			<a href="/entertainment/ben-brako-explains-viral-semi-nude-photo-with-wife.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item">

						<div class="allmode-img"><a href="/sports/kwesi-nyantekyi-awaits-fifa-s-decision-as-45-days-ban-expires.html"><img src="/modules/mod_raxo_allmode/tools/tb.php?src=%2Fimages%2F2018%2Foct%2F22%2F1.11815463.jpg&amp;w=120&amp;h=80&amp;zc=1" width="120" height="80" title="Kwesi Nyantekyi awaits FIFA's decision as 45 days ban expires" alt="Kwesi Nyantekyi" /></a></div>
			
			
			<div class="allmode-right">

								<h3 class="allmode-title"><a href="/sports/kwesi-nyantekyi-awaits-fifa-s-decision-as-45-days-ban-expires.html">Kwesi Nyantekyi awaits FIFA's decision as 45 days ban expires</a></h3>
				
				
				
			</div>

			<a href="/sports/kwesi-nyantekyi-awaits-fifa-s-decision-as-45-days-ban-expires.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item">

						<div class="allmode-img"><a href="/sports/black-queens-ready-to-face-opponents-squarely-bashir-hayford.html"><img src="/modules/mod_raxo_allmode/tools/tb.php?src=%2Fimages%2F2018%2Foct%2F22%2FHayford.jpg&amp;w=120&amp;h=80&amp;zc=1" width="120" height="80" title="Black Queens ready to face opponents squarely- Bashir Hayford" alt="Bashir_Hayford" /></a></div>
			
			
			<div class="allmode-right">

								<h3 class="allmode-title"><a href="/sports/black-queens-ready-to-face-opponents-squarely-bashir-hayford.html">Black Queens ready to face opponents squarely- Bashir Hayford</a></h3>
				
				
				
			</div>

			<a href="/sports/black-queens-ready-to-face-opponents-squarely-bashir-hayford.html" class="allmode-readmore"></a>

		</li>

	
		<li class="allmode-item">

						<div class="allmode-img"><a href="/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.html"><img src="/modules/mod_raxo_allmode/tools/tb.php?src=%2Fimages%2F2018%2Foct%2F22%2Fknust-logo.jpg&amp;w=120&amp;h=80&amp;zc=1" width="120" height="80" title="KNUST Students to demonstrate today after Colleagues’ arrest" alt="KNUST students to demonstrate today" /></a></div>
			
			
			<div class="allmode-right">

								<h3 class="allmode-title"><a href="/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.html">KNUST Students to demonstrate today after Colleagues’ arrest</a></h3>
				
				
				
			</div>

			<a href="/general-news/knust-students-to-demonstrate-n-today-after-colleagues-arrest.html" class="allmode-readmore"></a>

		</li>

	
</ul>
</div>    </div>
    
</div>
        <div class=" bd-block-28 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300 x 600 Homepage -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-5493363406145616"
     data-ad-slot="7606888487"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>    </div>
    
</div>
        </div>
        </div>                    
                </div>
            </aside>
                    </div>
            
        </div>

    </div>
</div></div>
	
		<footer class=" bd-footerarea-1 bd-margins">
        <div class="bd-containereffect-23 container-effect container "><section class=" bd-section-2 bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed " id="section2" data-section-title="Red Footer With Social Icons">
    <div class="bd-container-inner bd-margins clearfix">
        <div class=" bd-layoutbox-9 bd-no-margins bd-no-margins clearfix">
    <div class="bd-container-inner">
        <div class=" bd-spacer-2 clearfix"></div>
	
		<div class=" bd-layoutcontainer-17 bd-columns bd-no-margins">
    <div class="bd-container-inner">
        <div class="container-fluid">
            <div class="row ">
                <div class=" bd-columnwrapper-39 
 col-sm-3
 hidden-xs">
    <div class="bd-layoutcolumn-39 hidden-xs bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-3 hidden-xs clearfix" >
            <div class=" bd-block-32 bd-own-margins " >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <h4>News Sections</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <ul class=""><li class="item-176"><a href="/politics.html"><span>Politics</span></a></li><li class="item-177 active"><a href="/general-news.html"><span>General News</span></a></li><li class="item-178"><a href="/lifestyle.html"><span>Lifestyle</span></a></li><li class="item-179"><a href="/entertainment.html"><span>Entertainment</span></a></li></ul>    </div>
    
</div>
        </div>
        </div></div>
</div>
	
		<div class=" bd-columnwrapper-23 
 col-sm-3
 hidden-xs">
    <div class="bd-layoutcolumn-23 hidden-xs bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-27 hidden-xs clearfix" >
            <div class=" bd-block-34 bd-own-margins " >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <h4>More News Section</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <ul class=""><li class="item-180"><a href="/tech.html"><span>Science/Tech</span></a></li><li class="item-181"><a href="/features.html"><span>Opinion</span></a></li><li class="item-182"><a href="/world.html"><span>World News</span></a></li><li class="item-187"><a href="/business.html"><span>Business News</span></a></li></ul>    </div>
    
</div>
        </div>
        </div></div>
</div>
	
		<div class=" bd-columnwrapper-61 
 col-sm-3
 hidden-xs">
    <div class="bd-layoutcolumn-61 hidden-xs bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-5 hidden-xs clearfix" >
            <div class=" bd-block-35 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-575c4d804921d99e"></script>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-78977309-1', 'auto');
  ga('send', 'pageview');

</script>
    </div>
    
</div>
        <div class=" bd-block-35 bd-own-margins " >
        
    <div class=" bd-blockheader bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <h4>About Us</h4>
    </div>
    
        
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <ul class=""><li class="item-185"><a title="Meet The Team" href="/meet-the-team.html"><span>Meet The Team</span></a></li><li class="item-184"><a href="/about-primenews.html"><span>About PrimeNews</span></a></li><li class="item-183"><a href="/terms-conditions.html"><span>Terms &amp; Conditions</span></a></li><li class="item-282"><a href="/primenews-sitemap.html"><span>Primenews Sitemap</span></a></li></ul>    </div>
    
</div>
        <div class=" bd-block-35 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles bd-bootstrap-tables bd-table-striped bd-table-bordered bd-table-hover bd-table-condensed">
        <div class="db8sitelastmodified">
        Last Modified: 22 Oct 2018, 10:53:.</div>    </div>
    
</div>
        </div>
        </div></div>
</div>
	
		<div class=" bd-columnwrapper-60 
 col-sm-3">
    <div class="bd-layoutcolumn-60 bd-column" ><div class="bd-vertical-align-wrapper"><a class="bd-imagelink-2  bd-own-margins "  href="https://www.primenewsghana.com">
<img class=" bd-imagestyles" src="https://www.primenewsghana.com/images/siteimages/NEW-PRIME-LOGO-BLUE---small.png"
 alt="Prime News Ghana .com Logo">
</a></div></div>
</div>
            </div>
        </div>
    </div>
</div>
	
		<div class=" bd-spacer-5 clearfix"></div>
	
		<div class=" bd-spacer-7 clearfix"></div>
	
		<p class=" bd-textblock-5 bd-content-element">
    © 2016 - 2018 Primenewsghana.com - subsidiary of Prime Network Ltd. All Rights Reserved.</p>
    </div>
</div>
    </div>
</section></div>
</footer>
	
		<div data-smooth-scroll data-animation-time="250" class=" bd-smoothscroll-1"><a href="#" class=" bd-backtotop-2 ">
    <span class="bd-icon-2 bd-icon "></span>
</a></div>
	
		<div class="bd-containereffect-3 container-effect container ">




</div>
			<!-- Google Analytics -->
			<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			
			ga('create', 'UA-78977309-1', 'auto');
			ga('send', 'pageview');
			
			</script>
			<!-- End Google Analytics --></body>
</html>